Raspberry Pi 4现在是OpenGL ES 3.1兼容,工作在Vulkan驱动启动

树莓派4型号b4于去年6月推出了一款新的Broadcom BCM2711具有升级的支持OpenGL ES 3.0图形API的videcore VI GPU的SoC。

一些驱动只实现了由Khronos Group定义的OpenGL 3.0/3.1 3D图形标准的一个子集,好消息是Raspberry Pi 4 Model B现在是OpenGL ES 3.1符合要求因为它通过了克洛诺斯的所有测试一致性测试套件。

树莓Pi 4 OpenGL ES 3.1符合

这意味着任何使用OpenGL ES 3.1 API编程的Linux都应该开箱即用,尽管在某些情况下可能存在测试套件没有检测到的问题/bug。

凡尔康API是OpenGL ES API的进化吗更高效因为它更好地利用了多核处理器。树莓派基金会(Raspberry Pi Foundation)有也开始工作在Vulkan上支持树莓派4,虽然驱动程序仍在进行很多工作,基本的三角演示(即“Hello World!”现在正在工作。

树莓派4 Vulkan
点击放大

树莓派基金会将图形开发工作外包给了一家位于西班牙的开源咨询公司Igalia并指出,全面支持将需要更长的时间,因为该公司迄今为止只对Vulkan司机进行了几周的工作。埃本·厄普顿提到,人们还需要一段时间才能在派上试用Vulkan:

一旦我们有一些适合踢轮胎的东西,我们将做另一个帖子与说明。大概六个月左右吧。

到那时,他们可能会发布运行在Arm核心上的代码,但要达到Vulkan的要求还需要更长的时间。

分享:

支持CNX软件!www.yabo188.vip通过捐款贝宝cryptocurrencies成为一个老板Patreon,或者购买评论样本

订阅
通知的
客人
评论表单收集您的姓名、电子邮件和内容,以便我们跟踪网站上的评论。请阅读并接受我们的网站条款和隐私政策发表评论。
3.评论
最古老的
最新的
m] [sko
1年前

让我们为ubuntu 20.04在树莓派4上的工作祈祷(使用gpu加速)

哈维尔
哈维尔
10个月前

还没有工作,新安装的raspian 32位,直接配置vlc为opengl,也使它在raspi-config中描述。VLC看起来像跳舞的光。我遵循了所有关于安装opengl的说明,使用raspi-conf亚博体育官下载ig,启用相机,禁用相机,config.txt中的所有类型的调整,没用的,今天第一个2020年11月不工作!
太棒了!

广告